Page 1 of 1

Adding local playback option

PostPosted: Sun Mar 11, 2012 11:01 pm
by Renegade
I'll be adding an option to locally playback an audio file through HLDJ (using the computers sound drivers). This means you will be able to use HLDJ as a very basic audio player. It's been tested with wav files (and may work with other file types depending on the codecs you have installed; if you want to test with other file types, set Display Mode to "all files & folders" in the game's advanced options).

Stay tuned

Re: Adding local playback option

PostPosted: Mon Mar 12, 2012 2:30 am
by Renegade
If you're interested in trying it out:
hldj32_1.7.0alpha_preview.zip
(1.48 MiB) Downloaded 1730 times

to enable this feature:
see options -> playback, enable local playback, then try loading a song
currently the only way to stop a song is to load another one (or let it finish), so for now it might be handy to have a blank or short audio file to load to stop the previous song.

Re: Adding local playback option

PostPosted: Tue Oct 23, 2012 8:32 am
by Konoha Senpuu
Where exactly can i enable 'Show All'? can i see a screenshot.

Re: Adding local playback option

PostPosted: Tue Oct 23, 2012 10:44 pm
by Renegade
enable "all files & folders":
advanced.png

Re: Adding local playback option

PostPosted: Tue Oct 23, 2012 11:53 pm
by Konoha Senpuu
Thanks that helped a lot with the screen shot, but my mp3 songs don't work in-game, i enabled "all files and folders" and "playback" i could see the files in my songs list but they just produce radio noise for 2 seconds and then nothing. I get my mp3 songs from a Youtube video converter website. http://www.video2mp3.net/index.php

I play Age of chivalry BTW a source mod, i use the Hldj from the original website the latest one and i use the in-built converter and everything works fine, except i don't use mp3 songs which isn't that good because the conversion reduces sound quality and i can hear it, the sound is slightly blurred, just saying.

Re: Adding local playback option

PostPosted: Wed Oct 24, 2012 6:25 pm
by Renegade
only the version posted in this thread supports local playback.

Re: Adding local playback option

PostPosted: Wed Oct 24, 2012 9:37 pm
by Konoha Senpuu
Yes i meant this version posted in this thread won't play my mp3 songs. I have both hldj programs (from the home page, and from this thread), i'm just using the homepage one at the moment.

Re: Adding local playback option

PostPosted: Sat Oct 27, 2012 1:20 am
by Renegade
I tried an mp3 and it does not work for me either, although at some point I believe it had. I think it depends on the codecs/drivers you have installed for your audio device and even then it may not reliably play non-wave audio.

so I'd recommend using wav's (also don't forget to enable Local Playback in Options)
(or if you want to experiment, try installing a codec pack such as "k-lite". I've heard that renaming the mp3's to .wav may also work).